7 Temmuz 2010 Çarşamba

Excel eger formulu

EĞER FORMÜLÜ

Eğer B5 hücresi Boşsa C1 hücresini boş bırak boş değilse B1 dolu yaz

=EĞER(B1="";"";"B1 DOLU")


'Eğer B5 Hücresi 1 Zayıf 2 ise iyi yazdıran formül

=EĞER(B5=1;"Zayıf";EĞER(B5>=2;"İyi")))


'Eğer B1 Hücresi Sıfırdan büyükse hücreye 1 yaz değilse boş bırak

=EĞER(B1>0;1;"")


=EĞER(VE( Formülünün kullanımı) Soru:formül kullanarak mesela 2 ile 3 arası "iyi" 3-5 arası "pekiyi" olacak?

=EĞER(VE(B5>=1;B5<=2);"Zayıf";EĞER(VE(B5>=2;B5<=3) ;"İyi";EĞER(VE(B5>=4;B5<=5);"Pekiyi"))) Eğer D3 Hücresi ile A3 Hücrelerindeki veri aynı ise B2 deki değeri D3 Hücresinin önüne yazar. (Formülü E3 Hücresine Yazınız.) =EĞER(D3=A3;B3;"") MİNİMUM - MAKSİMUM ORTANCA VE ORTALAMA FORMÜLLERİ MİN - A1 VE A10 HÜCRELERİ ARASINDAKİ EN KÜÇÜK DEĞERİ BULUR =MİN(A1:A10) MAK- A1 VE A10 HÜCRELERİ ARASINDAKİ EN BÜYÜK DEĞERİ BULUR =MAK(A1:A10) BELİRTİLEN ARALIKTAKİ EN BÜYÜK DEĞERDEN EN KÜÇÜK DEĞERİ ÇIKARIR =MAK(C5:E8)-MİN(C5:E8) ORTANCA- A1 VE A10 HÜCRELERİ ARASINDAKİ ORTANCA DEĞERİ VERİR =ORTANCA(A1:A10) ORTALAMA FORMÜLÜ Belirtilen Hücreler arasındaki değerlerin ortalamasını verir =ORTALAMA(EĞER(A1:A10=0;0;A1:A10)) TARİH FORMÜLLERİ Haftanın Günü =EĞER(YADA(HAFTANINGÜNÜ(A4+1)=1;HAFTANINGÜNÜ(A4+1) =7);A4+3;A4+1) Ayın Son Gününü Verir =TARİH(YIL(A1);AY(A1)+1;0) Ayın Gününü Yazar =TARİH(YIL(A1);AY(A1);1)+ELEMAN(HAFTANINGÜNÜ(TARİH (YIL(A1);AY(A1);1));1;0;0;0;0;0;2) Ayın Son Gününü Verir =TARİH(YIL(A1);AY(A1)+1;0)-(MAK(0;HAFTANINGÜNÜ(TARİH(YIL(A1);AY(A1)+1;0);2)-5)) Bir Önceki Ayın Son Tarihinin verir =TARİH(YIL(A1);AY(A1);0) iki Tarih arasındaki hafta ve günü verir =NSAT((B1-A1)/7)&" Hafta "&MOD(B1-A1;7)&"Gün" ay ve gün manuel yıl otomatik =TARİH(YIL(ŞİMDİ());12;25) A1 HÜCRESİNE =BUGÜN() FORMÜLÜNÜ GİRİN B1 HÜCERİSİNE A1 HÜCRESİNDEKİ TARİHİN; 1 GÜN SONRASININ İÇİN : =A1+1 1 HAFTA SONRASI İÇİN : =A1+7 1 Ay Sonrası için : =TARİH(YIL(A1);AY(A1)+1;GÜN(A1)) 1 Yıl Sonrası İçin : =TARİH(YIL(A1)+1;AY(A1);GÜN(A1)) Bir önceki ayın Son gününün tarihi için :=TARİH(YIL(A1);AY(A1);GÜN(A1)-GÜN(A1)) Bir Sonraki Ayın Tarihi için : =TARİH(YIL(A1);AY(A1)+1;GÜN(A1)-GÜN(A1)+1) Formüllerinden yararlanabilirsiniz. SAYMA İŞLEMLERİ A3 HÜCRESİ İLE A12 HÜCRELERİ ARASINA GİRİLEN AYNI VERİLERİ SAYAR =EĞERSAY(A3:A12; A3:A12) BELİRTİLEN HÜCRE ARALIĞINDAKİ HÜCRELERİ SAY =BAĞ_DEĞ_SAY =BAĞ_DEĞ_SAY(C5:E8) BELİRTİLEN HÜCRE ARALIĞINDAKİ DOLU HÜCRELERİ SAY =BAĞ_DEĞ_DOLU_SAY =BAĞ_DEĞ_DOLU_SAY(C5:E8) A2:A16 ARASINDAKİ BOŞ HÜCRELERİ SAYAR =BOŞLUKSAY(A2:A16) MAKROLARLA FORMÜL İŞLEMLERİ MAKRO İLE TOPLAMA VE BÖLME YAPMA Sub topla_böl() Range("C1") = (Range("A1") + Range("A2")) / 2 End Sub E1 Hücresi ile E15 HÜCRELERİNİN TOPLAMINI A1 E YAZ Sub Topla() [A1].Value = Application.Sum([E1:E15]) End Sub E1 Hücresi ile E15 HÜCRELERİNİN TOPLAMINI A1 E YAZ Sub Topla() [A1].Value = Application.Sum([E1:E15]) End Sub MAKRO İLE ÇARPMA YAPMA - D1 HÜCRESİNE A1 VE B1 HÜCRELERİNİN ÇARPINI YAZ Sub Carp() Range("D1") = Range("A1") * Range("B1") Range("D1").Formula = "=(A1 * A1)" End Sub ÇALIŞMA KİTABININ İLK SAYFASINI AKTİF ET VE A3 HÜCRESİNE 5 YAZ. A4 HÜCERİSEN FORMÜL GİR Sub degerformul() Worksheets(1).Activate ActiveSheet.Range("A3").Value = 5 ActiveSheet.Range("A4").Formula = "=A5+B8" End Sub AKTİF SAYFADAKİ FORMÜLLERİ BULAN VE TOPLAM FORMÜL SAYISINI MESAJ KUTUSUNDA GÖSTEREN KODLAR Sub formullerim() Dim R As Integer R = 0 Range(Cells(1, 1), Selection.SpecialCells(xlLastCell)).Select For Each Cell In Selection If Left(Cell.Formula, 1) = "=" Then R = R + 1 End If Next Cell Selection.SpecialCells(xlFormulas, 23).Select MsgBox "Toplam " & R & " Formül " & _ ActiveSheet.Name & " Adlı Sayfada Bulundu" End Sub AKTİF SAYFADAKİ FORMÜLLERİ BULUP YENİ SAYFAYA LİSTELER Sub formullistele() Dim FormulaCells As Range, Cell As Range Dim FormulaSheet As Worksheet Dim Row As Integer ' Create a Range object for all formula cells On Error Resume Next Set FormulaCells = Range("A1").SpecialCells(xlFormulas, 23) ' Exit if no formulas are found If FormulaCells Is Nothing Then MsgBox "No Formulas." Exit Sub End If ' Add a new worksheet Application.ScreenUpdating = False Set FormulaSheet = ActiveWorkbook.Worksheets.Add FormulaSheet.Name = "Formulas in " & FormulaCells.Parent.Name ' Set up the column headings With FormulaSheet Range("A1") = "Address" Range("B1") = "Formula" Range("C1") = "Value" Range("A1:C1").Font.Bold = True End With ' Process each formula Row = 2 For Each Cell In FormulaCells Application.StatusBar = Format((Row - 1) / FormulaCells.Count, "0%") With FormulaSheet Cells(Row, 1) = Cell.Address _ (RowAbsolute:=False, ColumnAbsolute:=False) Cells(Row, 2) = " " & Cell.Formula Cells(Row, 3) = Cell.Value Row = Row + 1 End With Next Cell ' Adjust column widths FormulaSheet.Columns("A:C").AutoFit Application.StatusBar = False End Sub AKTİF HÜCREDEKİ FORMÜLÜ VEREN MSGBOX ÇALIŞMASI Sub AddressFormulasMsgBox() 'Displays the address and formula in message box For Each Item In Selection If Mid(Item.Formula, 1, 1) = "=" Then MsgBox "The formula in " & Item.Address(rowAbsolute:=False, _ columnAbsolute:=False) & " is: " & Item.Formula, vbInformation End If Next End Sub FAREYLE SEÇTİĞİNİZ HÜCRELERDEKİ FORMÜLLERİ AÇIKLAMA OLARAK YAZDIRAN KODLAR Sub formulacikla() Dim cell As Range Selection.ClearComments For Each cell In Selection If cell.HasFormula Then cell.AddComment cell.Formula cell.Comment.Visible = False cell.Comment.Shape.TextFrame.AutoSize = True End If Next cell End Sub HÜCRELERE VERİLEN AD'LARI SİLER Sub DeleteRangeNames() Dim rName As Name For Each rName In ActiveWorkbook.Names rName.Delete Next rName End Sub B1:G13 HÜCRELERİ ARASINDAKİ VERİLERİ SIFIR YAP Sub ResetTest1() For Each n In Range("B1:G13") ' Substitute your range here If n.Value <> 0 Then
n.Value = 0
End If
Next n
End Sub


AKTİF HÜCREYE GİRİLEN RAKAMLARI ALTAKİ STATUSBAR DA TOPLAYAN KODLAR

Private Sub Worksheet_SelectionChange(ByVal Target As Excel.Range)
Dim myVar As Double
myVar = Application.Sum(Columns(Target.Column))
If myVar <> 0 Then
Application.StatusBar = Format(myVar, "###,###")
Else
Application.StatusBar = False
End If
End Sub


TOPLAM FORMÜLÜNÜ HER DEFASINDA BİR ALTA TOPLAYAN KODLAR

Sub Addieren()
Dim rng As Range
Set rng = Cells(Rows.Count, 1).End(xlUp).Offset(1, 0)
rng.Formula = "=SUM(A1:A" & rng.Row - 1 & ")"
End Sub


VBA YAZILAN FORMÜLLERE KESİN BAŞVURU İŞARETİ KOYMAK İÇİN KULLANILAN KODLAR ($A$4)

Sub VariableInFormel()
Dim iCol As Integer
iCol = Range("B1").Value
Range("B2").Formula = _
"=SUM(R1C" & iCol & ":R100C" & iCol & ")"
End Sub

Hiç yorum yok:

Yorum Gönder

Yorum Gönder